在类Unix系统中安装Nim

使用choosenim安装

choosenim是一个Nim语言安装器。 它能帮助您轻松地在Nim的各个版本之间切换,无论是最新的稳定版本还是最新的开发版本。

使用choosenim安装Nim最新的稳定版本, 只需要在你的终端中运行下方的命令,然后根据屏幕上的说明操作即可:

curl https://nim-lang.org/choosenim/init.sh -sSf | sh

手动安装

Linux的预构建二进制文件

下载x86压缩包 SHA256
下载x86_64压缩包 SHA256

从源码构建

下载源文件压缩包 SHA256

下载压缩的存档文件后,将其内容解压到所需的安装目录中。

在二进制发行版中提供了预先构建好的二进制文件。

如果是从源码自己构建的话,新打开一个命令行窗口, 使用cd命令进入到你刚才解压的文件夹,然后执行下面的命令以完成构建:

sh build.sh
bin/nim c koch
./koch tools

手动安装需要配置PATH环境变量

编译器和工具的二进制文件都位于bin目录中。 要使用Nim进行开发,需要在你的 PATH环境变量 中添加以下两个目录::

关于编译器依赖的说明

Nim编译器编译软件时需要一个C编译器。 您必须单独安装它,并确保它在您的PATH中。

macOS

在Mac中,你可以简便地安装最新版本的clang。 就像这样:

参考: Quora

Linux

你可能已经安装了编译器。 如果没有的话,用你的包管理器在 gccclang中选一个装上。

Other依赖

下面展示了一个包含了其他依赖的列表, 你需要先确保安装了这些依赖,才能使用Nim。

必要时,可以使用包管理器安装这些依赖项。

使用包管理器安装

Arch Linux

pacman -S nim

Debian / Ubuntu

apt-get install nim

Docker

社区管理的Docker镜像 在Docker Hub上发布,包括了编译器和Nimble。 有独立脚本和Nimble包的镜像。

获取最新的稳定镜像:

docker pull nimlang/nim

获取最新的开发镜像:

docker pull nimlang/nim:devel

Fedora

dnf install nim

FreeBSD

pkg install nim

macOS

brew install nim

openSUSE

zypper in nim

Snap

获取最新稳定版本:

snap install nim-lang --classic

获取最新长期支持(LTS) 1.0.x 版本:

snap install nim-lang-lts-1 --classic

获取最新每日构建版本:

snap install nim-lang-nightly --classic

Void Linux

xbps-install -S nim